WordPress plugin and theme support: please keep us up to date!

As I am deploying quite a few WordPress installations as of late, and have been working with WordPress for a few years now, one of the shortcomings I’ve seen is that the plugin and theme databases tend to become outdated.  While I don’t expect WordPress to police each and every entry, I would like some sort of automated system in place that will downgrade plugins or themes that are dated.

It is frustrating to wade through a dozen or two plugins, only to find that some of the more attractive plugins haven’t been updated in over a year, or have not been verified to work since a few versions ago.  In my case, I never install a plugin that is over a year old and even then, I take a good, long look at a plugin if it is more than six months behind.  While I realize many plugins need no changes, there still needs to be some sort of status update from the developer that the plugin is still current and more importantly, supported.

That’s the main issue right there: support.  When I see a plugin that hasn’t seen a release in over a year, I assume it is abandoned, and no longer supported.  I do not install plugins that have been abandoned, especially for a paying client.  I rarely ever need or use support for a plugin, but I do expect that support to be there should I need it.

And there is another issue I’ve had as of late:  two plugins I’ve used have been broken in their most recent releases.  Plugin authors need to keep an eye on the wordpress.org forum for their plugin or theme, and answer (or at least acknowledge) any posts we make about them.  I have had issues with three plugins over the past two weeks.  One author was right on top of getting back to me with an answer in the forum.  The other two?  Still waiting.  On each, I’ve posted a reply asking if the plugin is still supported.  At least if it’s not, I can move along and find another plugin that will work.

What could WordPress.org do?  I could suggest having some sort of alert mechanism in place that marks a plugin as out of date and possibly abandoned if it hasn’t been touched in a year.  It should also automatically issue an email to the developer, telling them to log in and verify the validity of the plugin within 15 days at the risk of having it flagged as inactive and unsupported.  Likewise, for support threads that go unanswered, I would also automatically deactivate a plugin’s status (to inactive/unsupported) if the thread is not replied to by the author within 15 days.

Sure it’s a bit strict, but the WordPress plugin and theme databases really need a good cleaning.  Help us all by weeding out the dead so we can encourage new growth.

This entry was posted in Development, Wordpress. Bookmark the permalink.